2017-10-28

Visual Studio JavaScript 編輯視窗出現 ECMAScript 錯誤提示

因為要要處理前端頁面效果,在參考網路分享的 Vue.js 套件時,一直出現 ECMAScript 錯誤提示,雖然不影響實際功能執行,但編輯畫面上一直出現紅線的錯誤提示不解決還是覺得心裡有疙瘩,所以找了一下解決方式,順手紀錄一下


錯誤訊息

  • 訊息內容
    ECMAScript 2015 feature. Your current language level is: ECMAScript 5
    
  • 錯訊截圖

    1ecma5

解決方式

  1. Visual Studio 主選單 Resharper --> Options...

    2resharpertools

  2. Code Editing --> JavaScript --> Inspections --> JavaScript language level

    調成所需要的 ECMAScript 版本即可

    3scriptlevel

心得

原本以為是 Visual Studio 的提示訊息,原來是 Resharper 的,幸虧 Resharper 的相關設定非常彈性,絕大部份需求都可以滿足

參考資訊

  1. How can I configure Resharper's language level for ECMAScript 6?

沒有留言:

張貼留言